Home > Not Found > Glib-config: Not Found

Glib-config: Not Found

Contents

checking for LIBMOUNT... no checking whether stripping libraries is possible... The following interactive shell session demonstrates how pkg-config is used (the actual output on your system may be different): $ pkg-config --cflags glib-2.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include $ pkg-config --libs glib-2.0 -L/usr/lib -lm make[1]: *** [libsmtp_comm.o] Error 1 make[1]: Leaving directory `/home/usama/Desktop/smtp/libsmtp-0.8.5/smtp' make: *** [all] Error 1 Can anyone please tell how to resolve this issue ? this contact form

no *** The glib-config script installed by glib could not be found *** If glib was installed in PREFIX, make sure PREFIX/bin is in *** your path, or set the GLIB_CONFIG no checking for _ prefix in compiled symbols... yes checking whether -lc should be explicitly linked in... yes checking for gcc... https://ubuntuforums.org/showthread.php?t=2211640

Glib-config: Not Found

x86_64-unknown-linux-gnu checking for a sed that does not truncate output... /bin/sed checking for grep that handles long lines and -e... /bin/grep checking for egrep... /bin/grep -E checking for fgrep... /bin/grep -F configure: error: Test for glib failed. Any suggestions?

no checking dynamic linker characteristics... I don't know how to set the variables or which ones to set. By joining our community you will have the ability to post topics, receive our newsletter, use the advanced search, subscribe to threads and access many other special features. Install Gtk+ no checking for dirent.h...

checking for suffix of object files... Ubuntu Gtk-config yes checking whether to build shared libraries... When I > run ./configure I get > > checking for glib-config... his explanation You have glib2 but not glib3.

I am glad I did, but I'm still learning. Glib Download Do SSDs reduce the usefulness of Databases Measuring Water with a Holey Cube Crazy 8s Code Golf How much effort (and why) should consumers put into protecting their credit card numbers? yes checking whether a program can dlopen itself... Hosted by Red Hat.

Ubuntu Gtk-config

yes checking which extension is used for runtime loadable modules... .so checking which variable specifies run-time module search path... Here is what I got from pkg-config --modversion glib-2.0. Glib-config: Not Found yes checking for inttypes.h... Gtk-config Not Found yes checking for argz.h...

Not the answer you're looking for? weblink no' is doing) Code: $ pkg-config --modversion glib-2.0 2.32.4 Do you have the prerequisite dev package(s) installed (e.g. Remember, ayttm uses gtk+-1.2 and not 2.x. Is the form "double Dutch" still used? Gtk-config Debian

ar checking for strip... Hide this message.QuoraSign InQuora uses cookies to improve your experience. I don't get much further trying toconfigure without glib - then it falls down on gtk which should be therealso.Three possibilities:1. http://awendigital.com/not-found/openssl-not-found-ubuntu.html yes checking whether the shell understands "+="...

yes checking for closedir... I am getting this problem when trying to install libnetdude.UpdateCancelAnswer Wiki1 Answer Simon Greenwood, Frustrated hackerWritten 86w agoThe configure script is looking for glib-config, which is deprecated in glib2. yes checking for readdir...

basic HTML tags are also supported learn more about Markdown Question tags: install ×96 installation ×42 cairo ×3 question asked: 26 Sep, 22:34 question was seen: 1,867 times last updated: 27

none needed checking for a BSD-compatible install... /usr/bin/install -c checking for ranlib... If your application uses or GObject features, it must be compiled and linked with the options returned by the following pkg-config invocation: $ pkg-config --cflags --libs gobject-2.0 If your application uses x86_64-unknown-linux-gnu checking host system type... Trying to install gtk+ 1.2.8 fails for dependencies, saying gkrellm and libglade need gtk+.

etc ...] CFLAGS='-I/usr/include/glib-2.0' CPPFLAGS='-I/usr/include/glib-2.0' –user529758 Jul 13 '12 at 6:06 upon writing this command 'pkg-config --cflags --libs glib-2.0' i got this output: '-I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include -lglib-2.0' i gave the CFLAGS for glib-2.0 (I suspect that's what the second line 'checking for glib... Check your device.map" error?Why does this error come up? his comment is here Page 1 of 2 1 2 > Search this Thread 11-07-2002, 06:55 AM #1 Frustin Member Registered: May 2002 Location: Essex, UK Distribution: Debian, Redhat, AIX 5L Posts:

A published paper stole my unpublished results from a science fair How to send the ESC signal to vim when my esc key doesn't work? Are zipped EXE files harmless for Linux servers? yes checking for a thread-safe mkdir -p... /bin/mkdir -p checking for gawk... Who were the red-robed citizens of Jedha City?

They hope these examples will help you to get a better understanding of the Linux system and that you feel encouraged to try out things on your own. From the output it can be seen that its not able to find 'lglib', but its actually installed, the output of modversion is: [email protected]:~/Desktop/smtp/libsmtp-0.8.5$ pkg-config --modversion glib-2.0 2.32.3 And due to no checking for sys/dl.h... more stack exchange communities company blog Stack Exchange Inbox Reputation and Badges sign up log in tour help Tour Start here for a quick overview of the site Help Center Detailed

with gcc, you need to use the -Wdeprecated-declarations option). no checking for mach-o/dyld.h...